Lines Matching full:throw
26 void s1() throw();
27 void s2() throw(int);
28 void s3() throw(A);
29 void s4() throw(B1);
30 void s5() throw(D);
32 void s7() throw(int, float);
33 void (*s8())() throw(B1); // s8 returns a pointer to function with spec
34 void s9(void (*)() throw(B1)); // s9 takes pointer to function with spec
43 void (*t1)() throw() = &s1; // valid in fnptrs()
46 void (&t2)() throw() = s2; // expected-error {{not superset}} in fnptrs()
47 void (*t3)() throw(int) = &s2; // valid in fnptrs()
48 void (*t4)() throw(A) = &s1; // valid in fnptrs()
58 void (*t6)() throw(B1); in fnptrs()
65 void (*(*t7)())() throw(B1) = &s8; // valid in fnptrs()
66 void (*(*t8)())() throw(A) = &s8; // expected-error {{return types differ}} in fnptrs()
67 void (*(*t9)())() throw(D) = &s8; // expected-error {{return types differ}} in fnptrs()
68 void (*t10)(void (*)() throw(B1)) = &s9; // valid in fnptrs()
69 void (*t11)(void (*)() throw(A)) = &s9; // expected-error {{argument types differ}} in fnptrs()
70 void (*t12)(void (*)() throw(D)) = &s9; // expected-error {{argument types differ}} in fnptrs()
75 struct Str1 { void f() throw(int); }; // expected-note {{previous declaration}}
82 void (Str1::*pfn1)() throw(int) = &Str1::f; // valid in mfnptr()
84 void (Str1::*pfn3)() throw() = &Str1::f; // expected-error {{not superset}} in mfnptr()