Lines Matching refs:exponent
1113 summary: Binary mantissa and exponent
1115 Returns the binary mantissa and exponent of v, i.e. <code>v == mantissa * 2 ^ exponent</code>.
1212 summary: Base two exponent
1214 Returns the base two exponent of a value, where the mantissa is between
1242 summary: Creates a floating point from mantissa and exponent
1244 Returns the floating point created from the mantissa and exponent,
1245 i.e. (mantissa * 2 ^ exponent).
1266 arg: int exponent
1275 arg: int exponent
1424 summary: Base two exponent
1426 Returns the base two exponent of a value, where the mantissa is between
2463 summary: Approximate positive base raised to an exponent
2465 Fast approximate (base ^ exponent).
2784 summary: Base raised to an exponent
2786 Returns base raised to the power exponent, i.e. base ^ exponent.
2788 @pown() and @powr() are similar. @pown() takes an integer exponent. @powr() assumes the
2810 summary: Base raised to an integer exponent
2812 Returns base raised to the power exponent, i.e. base ^ exponent.
2814 @pow() and @powr() are similar. The both take a float exponent. @powr() also assumes the
2836 summary: Positive base raised to an exponent
2838 Returns base raised to the power exponent, i.e. base ^ exponent. base must be >= 0.
2841 @pow() takes a float exponent while @pown() take an integer.