Lines Matching refs:constexpr
17 constexpr Literal() {} in Literal()
27 constexpr int ImplicitlyVirtual() const { return 0; } in ImplicitlyVirtual()
30 constexpr int a = ImplicitVirtualFromDependentBase<S>().ImplicitlyVirtual(); // expected-error {{co…
31 constexpr int b = ImplicitVirtualFromDependentBase<T>().ImplicitlyVirtual(); // ok
32 constexpr int c = ImplicitVirtualFromDependentBase<S>().ImplicitVirtualFromDependentBase<S>::Implic…
35 constexpr R F() const { return 0; } in F()
37 constexpr int d = ConstexprMember<int>().F(); // ok
38 constexpr int e = ConstexprMember<NonLiteral>().F(); // expected-error {{constant expression}} expe…
41 constexpr ConstexprCtor(P...) {} in ConstexprCtor()
43 constexpr ConstexprCtor<> f1() { return {}; } // ok in f1()
44 constexpr ConstexprCtor<int> f2() { return 0; } // ok in f2()
45 constexpr ConstexprCtor<NonLiteral> f3() { return { 0 }; } // expected-error {{never produces a con… in f3()
46 constexpr ConstexprCtor<int, NonLiteral> f4() { return { 0, 0 }; } // expected-error {{never produc… in f4()
52 …constexpr T1() {} // expected-error {{constexpr constructor not allowed in struct with virtual bas… in T1()
58 constexpr T2() {} in T2()
60 constexpr T2<Literal> g2() { return {}; } in g2()
64 constexpr T3() {} in T3()
66 constexpr T3<Literal> g3() { return {}; } // ok in g3()
67 constexpr T3<VirtBase> g4() { return {}; } // expected-error {{not a literal type}} in g4()