Lines Matching refs:constexpr
6 constexpr int f(); // expected-warning {{C++14}}
7 constexpr int g() const;
8 constexpr int h(); // expected-warning {{C++14}}
10 static constexpr int Sf();
11 /*static*/ constexpr void *operator new(size_t) noexcept;
12 template<typename T> constexpr T tm(); // expected-warning {{C++14}}
13 template<typename T> static constexpr T ts();
28 constexpr int S::f() const { return 0; } in f()
29 constexpr int S::g() { return 1; } // expected-warning {{C++14}} in g()
30 constexpr int S::h() { return 0; } // expected-warning {{C++14}} in h()
32 constexpr int S::Sf() { return 2; } in Sf()
33 constexpr void *S::operator new(size_t) noexcept { return 0; } in operator new()
34 template<typename T> constexpr T S::tm() { return T(); } // expected-warning {{C++14}} in tm()
35 template<typename T> constexpr T S::ts() { return T(); } in ts()
42 constexpr bool is_on() const; // ok (dr1684)
47 constexpr int bar(int x, int y) // expected-note {{here}} in bar()
57 static constexpr bool isDebugFlag();