Lines Matching refs:constexpr
5 constexpr int a = 0;
9 constexpr int *b = &i;
12 constexpr int &c = i;
15 constexpr int (*d)(int) = 0;
20 constexpr int ni1; // expected-error {{default initialization of an object of const type 'const int…
21 constexpr struct C { C(); } ni2; // expected-error {{cannot have non-literal type 'const struct C'}…
22 constexpr double &ni3; // expected-error {{declaration of reference variable 'ni3' requires an init…
24 constexpr int nc1 = i; // expected-error {{constexpr variable 'nc1' must be initialized by a consta…
25 constexpr C nc2 = C(); // expected-error {{cannot have non-literal type 'const C'}}
27 constexpr int &nc3 = f(); // expected-error {{constexpr variable 'nc3' must be initialized by a con…
28 constexpr int nc4(i); // expected-error {{constexpr variable 'nc4' must be initialized by a constan…
29 constexpr C nc5((C())); // expected-error {{cannot have non-literal type 'const C'}}
31 constexpr int &nc6(f()); // expected-error {{constexpr variable 'nc6' must be initialized by a cons…
36 constexpr pixel ur = { 1294, 1024 }; // ok
37 constexpr pixel origin; // expected-error {{default initialization of an object of con…