Lines Matching refs:noexcept

40 static_assert(noexcept(IC0()), "IC0() does not throw");
41 static_assert(!noexcept(IC1()), "IC1() throws");
46 NoThrowMove(NoThrowMove &&) noexcept;
48 NoThrowMove &operator=(NoThrowMove &&) const noexcept;
51 NoThrowMoveOnly(NoThrowMoveOnly &&) noexcept;
52 NoThrowMoveOnly &operator=(NoThrowMoveOnly &&) noexcept;
63 static_assert(!noexcept(X(X::val())), "");
64 static_assert(!noexcept(X::ref() = X::val()), "");
72 ThrowingBase() noexcept(false);
73 ThrowingBase(const ThrowingBase&) noexcept(false);
74 ThrowingBase(ThrowingBase&&) noexcept(false);
75 ThrowingBase &operator=(const ThrowingBase&) noexcept(false);
76 ThrowingBase &operator=(ThrowingBase&&) noexcept(false);
77 ~ThrowingBase() noexcept(false);
80 Derived() noexcept(false) = default;
81 Derived(const Derived&) noexcept(false) = default;
82 Derived(Derived&&) noexcept(false) = default;
83 Derived &operator=(const Derived&) noexcept(false) = default;
84 Derived &operator=(Derived&&) noexcept(false) = default;
85 ~Derived() noexcept(false) = default;
96 Derived3() noexcept(true) = default; // expected-error {{does not match the calculated}}
97 …Derived3(const Derived3&) noexcept(true) = default; // expected-error {{does not match the calcula…
98 … Derived3(Derived3&&) noexcept(true) = default; // expected-error {{does not match the calculated}}
99 …Derived3 &operator=(const Derived3&) noexcept(true) = default; // expected-error {{does not match …
100 …Derived3 &operator=(Derived3&&) noexcept(true) = default; // expected-error {{does not match the c…
101 ~Derived3() noexcept(true) = default; // expected-error {{does not match the calculated}}
119 Base(X<0>) noexcept(true);
120 Base(X<1>) noexcept(false);
133 friend Derived::Derived(X<1>) noexcept(false);
136 static_assert(!noexcept(Derived{X<5>{}}), "");