Lines Matching refs:IntHolder
3 struct IntHolder { // expected-note{{here}} // expected-note 2{{candidate constructor (the implicit… struct
4 IntHolder(int); // expected-note 2{{candidate constructor}}
25 IntHolder &test_X_IntHolderInt(X<IntHolder, int> xih) { in test_X_IntHolderInt() argument
29 X<IntHolder, int>::Inner inner; // expected-note {{first required here}} in test_X_IntHolderInt()
31 return X<IntHolder, int>::value; // expected-note{{instantiation}} in test_X_IntHolderInt()
37 void X<IntHolder, long>::f() { } in f()
40 struct X<IntHolder, long>::Inner {
42 IntHolder value;
46 IntHolder X<IntHolder, long>::value = 17;
48 IntHolder &test_X_IntHolderInt(X<IntHolder, long> xih) { in test_X_IntHolderInt() argument
52 X<IntHolder, long>::Inner inner; // okay, uses specialization in test_X_IntHolderInt()
54 return X<IntHolder, long>::value; // okay, uses specialization in test_X_IntHolderInt()
58 X<IntHolder, long>::X() { } // expected-error{{instantiated member}} in X()