Lines Matching refs:blkid

588     for the blkid library (Closes: #604629)
751 * Teach mke2fs to get device topology information from blkid and use
764 * Enhance blkid to support .ko.gz files in the modules.dep parser
903 * Fix blkid to prefer the /dev/mapper/<name> device names over the
929 * Remove whole-disk entries from the blkid cache when partitions are found
957 * Teach the blkid library that starting in 2.6.29, ext4 can support
969 * Fix bug which could sometimes cause blkid to return an exit value of
972 * Fix blkid to deal with an ext3 filesystem with the test_fs flag
1015 * The blkid library will now recognize btrfs filesystems and swap
1113 * Make the blkid library more efficient for devicemapper devices,
1162 * Fix blkid cache validation and some possible blkid crashes
1188 * Add a new blkid -L option which pretty-prints the currently
1228 * Fix blkid handling of stale entries. (Closes: #487758, #487783)
1252 * Improve blkid probes for LVM volumes and swap partitions
1293 * Force blkid to revalidate a device if its mtime is newer than the
1356 * Fix blkid code to avoid segfaulting when a device mapper volume
1365 * Teach blkid to recognize LVM2 physical volumes
1381 * Add support for returning labels for UDF filesystems in the blkid
1383 * Fix bug in the blkid library where cached filesystems was not being
1386 * Add logic to the blkid library to automatically choose whether a
1420 * Add support for detecting HFS+ and ext4/ext4dev filesystems in blkid
1421 * Fix blkid's ntfs UUID handling so it is compatible with vol_id
1422 * Avoid a floating point exception when blkid tries to probe a corrpt
1461 * Enhance the blkid program to pretty-print control and meta
1487 * e2fsprogs: fix blkid whole-disk scanning heuristics
1492 * Fix typo in the summary section of the blkid man page
1549 * Fix divide-by-zero error in blkid's NTFS proving logic
1550 * Add new blkid -g option which causes the blkid cache to be garbage
1562 * Make the blkid library more paranoid about concluding a partition
1569 * blkid: Add support for detecting LUKS encrypted partitions
1583 * Fix blkid library to recognize MD 0.90 superblock on little endian
1585 * Fix blkid library to report the correct UUID from MD superblocks
1623 * Fix memory leak in blkid library. (Closes: #413661)
1701 * Add GFS/GFS2 support to the blkid library.
1702 * Fix blkid support of empty FAT filesystem labels
1703 * Avoid recursing forever due to symlinks in /dev by the blkid library
1782 * Add devmapper support to the blkid library.
1789 * Fix blkid's handling of verification timeouts when the system clock is
1793 * Enhance the blkid library to display the uuid of external journals for
1839 * Move the blkid and uuidgen binaries out of libblkid1 and libuuid1 and
1860 * Improve blkid's FAT/VFAT filesystem detection code so that it can find
1862 * Add support to extract iso9660 label information to the blkid library.
1863 * Add support to detect the reiser4 filesystem to the blkid library.
1864 * Add support for detecting software suspend partitions to the blkid library.
1865 * Fix the blkid library to notice when an ext2 filesystem is upgraded to
1940 * Make the blkid library much more efficient when a new device is added
1975 * Add further paranoia checks to the blkid, ext2fs, and ss libraries to
2012 * Make blkid -t work more consistently even when the cache file is not
2036 * Clarified and updated tune2fs and blkid man pages
2040 * Fix blkid -t to display all devices that match the specified criteria,
2042 * Add support for the blkid library to recognize Oracle ASM volumes.
2089 * The blkid library will return vfat in preference to msdos, and ext3 in
2114 * Fix bug in the blkid library when detecting the ocfs1 filesystem
2151 * Add support for the ocfs2 filesystem to the blkid library.
2166 * Fix blkid file descriptor and memory leak.
2186 * Clarified/corrected the copyright statements of the UUID and blkid
2188 * Added sanity check to the blkid library so that if current time is
2218 * Fix bug in the blkid library (introduced in 1.35-3) which caused
2223 * Add an -o option to the blkid program which allows the user to
2224 control the output format of blkid.
2225 * Fixed and cleaned up the tune2fs and blkid man pages (Closes: #238741)
2228 * Remove the only-partially-implemented -p option to blkid.
2379 * Remove unneeded files in debian directory: blkid-dev.substvars and
2419 * Fixed bug in blkid library which would cause it to spin forever if
2420 /proc is not mounted and /etc/blkid.tab is not present.
2421 * Improved the blkid library's UDF's probing functions.
2422 * Fixed the blkid library so it will remove delete the LABEL
2588 * Fix (one more time!) Apple Darwin port in blkid/getsize.c