Lines Matching refs:swap
36 swap period has elapsed since the last swap operation completed. The
44 where td is the time measured from the last completed buffer swap (or
45 call to enable the statistic) to when the next buffer swap completes, tf
47 depending on the swap interval as set by the GLX_SGI_swap_control or
52 buffer swap occurred within the time period required to maintain a
59 is taken from the completion of one swap to the issuance of the next.
62 issuance of a swap and the swap actually occurring.
64 There is also a mechanism to determine whether a frame swap was
112 The frame usage is measured as the percentage of the swap period elapsed
113 between two buffer-swap operations being committed. In unextended GLX the
114 swap period is the vertical refresh time. If SGI_swap_control or
115 MESA_swap_control are supported, the swap period is the vertical refresh
116 time multiplied by the swap interval (or one if the swap interval is set
119 If OML_sync_control is supported, the swap period is the vertical
122 the swap is committed before target_msc, and is greater than or equal to
131 that represents the current swap usage, as defined above.
140 If a swap is missed based in the rate control specified by the
141 <interval> set by glXSwapIntervalSGI or the default swap of once
171 application can call glXQueryFrameTrackingMESA for a final swap and