Lines Matching refs:dimension

83  over cells 4, 5, 6, and 7 in the X dimension, set xStart to 4 and xEnd to 8.
236 summary: Index in the Array0 dimension for the specified kernel context
238 Returns the index in the Array0 dimension of the cell being processed, as specified
254 This function returns 0 if the Array0 dimension is not present.
262 summary: Index in the Array1 dimension for the specified kernel context
264 Returns the index in the Array1 dimension of the cell being processed, as specified
267 Returns 0 if the Array1 dimension is not present.
275 summary: Index in the Array2 dimension for the specified kernel context
277 Returns the index in the Array2 dimension of the cell being processed,
281 Returns 0 if the Array2 dimension is not present.
289 summary: Index in the Array3 dimension for the specified kernel context
291 Returns the index in the Array3 dimension of the cell being processed, as specified
294 Returns 0 if the Array3 dimension is not present.
302 summary: Size of the Array0 dimension for the specified kernel context
304 Returns the size of the Array0 dimension for the specified kernel context.
307 Returns 0 if the Array0 dimension is not present.
317 summary: Size of the Array1 dimension for the specified kernel context
319 Returns the size of the Array1 dimension for the specified kernel context.
322 Returns 0 if the Array1 dimension is not present.
330 summary: Size of the Array2 dimension for the specified kernel context
332 Returns the size of the Array2 dimension for the specified kernel context.
335 Returns 0 if the Array2 dimension is not present.
343 summary: Size of the Array3 dimension for the specified kernel context
345 Returns the size of the Array3 dimension for the specified kernel context.
348 Returns 0 if the Array3 dimension is not present.