Lines Matching +full:- +full:- +full:upgrade

1 # -*- rpm -*-
10 Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{VERSION}.tar.gz
13 Buildroot: %{_tmppath}/%{name}-%{VERSION}-root
21 %define my_cc gcc -m32
29 Summary: Development environment for SYSLINUX add-on modules
36 (PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX). It also includes a tool,
41 sophisticated add-on modules. This package contains the libraries
63 %setup -q -n syslinux-%{VERSION}
68 make CC='%{my_cc}' -C sample tidy
71 rm -rf %{buildroot}
72 make CC='%{my_cc}' install-all \
77 make CC='%{my_cc}' -C sample tidy
78 mkdir -p %{buildroot}/etc
79 ( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
82 rm -rf %{buildroot}
85 %defattr(-,root,root)
113 if [ -f /boot/extlinux/extlinux.conf ]; then \
114 extlinux --update /boot/extlinux ; \
115 elif [ -f /boot/extlinux.conf ]; then \
116 mkdir -p /boot/extlinux && \
118 extlinux --update /boot/extlinux ; \
125 - Require NASM 2.03
126 - Package dosutil
129 - Use install targets; clean up various paths.
132 - Add man pages.
135 - Added netpbm-progs (provides pngtopnm) to BuildPrereq (this should be
139 - Move extlinux /boot stuff into /boot/extlinux.
142 - Hacks to make the 32-bit version build correctly on 64-bit machines.
145 - Add a syslinux-tftpboot module.
146 - Factor extlinux into its own package.
147 - Move to %{_datadir} (/usr/share).
150 - If /boot/extlinux.conf exist, run extlinux --update.
153 - Copy, don't link, *.c32 into /boot; rpm doesn't like breaking links.
156 - Put *.c32 into /boot.
159 - libsyslinux dropped in syslinux 3.00.
160 - Additional documentation.
161 - Add extlinux.
164 - Add a devel package for the com32 library added in 2.12.
166 * Wed Apr 16 2003 H. Peter Anvin <hpa@zytor.com> 2.04-1
167 - 2.04 release
168 - Add support for libsyslinux.so*
169 - Templatize for inclusion in CVS tree
172 - 2.03 release
173 - Add support for libsyslinux.a
174 - Add keytab-lilo.pl to the /usr/lib/syslinux directory
175 - Modernize syntax
176 - Support building on x86-64
179 - 2.02 release; no longer setuid
182 - Prepare for 2.01 release; make /usr/bin/syslinux setuid root
185 - Upgrade to 2.00.
188 - Upgrade to 1.76.
191 - Upgrade to 1.75.
194 - Upgrade to 1.74.
197 - Upgrade to 1.73.
200 - Upgrade to 1.72.
203 - Upgrade to 1.71.
204 - Update the title.
207 - Upgrade to 1.70.
210 - Upgrade to 1.67.
213 - Upgrade to 1.66.
216 - Upgrade to 1.65; make appropriate changes.
219 - Upgrade to 1.64.
222 - Upgrade to 1.63.
223 - Use make install since the stock SYSLINUX distribution now supports
227 - Upgrade to 1.62.
230 - Fix missing %files; correct modes.
233 - Upgrade to 1.61
234 - Install auxilliary programs in /usr/lib/syslinux
237 - 1.52
240 - 1.51pre7
243 - 1.51pre5
246 - 1.51pre3, with e820 detection
249 - rebuilt with fixed fileutils
252 - update to 1.49
253 - update ftp site
254 - clean up specfile
255 - add some useful documents
258 - add %%defattr (release 4)
261 - automatic rebuild
264 - use %%{_tmppath}
265 - change application group (Applications/Internet doesn't seem
267 - added BuildRequires
270 - initial packaging