1EGLSync eglCreateSync ( EGLDisplay dpy, EGLenum type, const EGLAttrib *attrib_list )
2// eglGetSyncAttrib pulled in with eglCreateSync stubs
3// EGLBoolean eglGetSyncAttrib ( EGLDisplay dpy, EGLSync sync, EGLint attribute, EGLAttrib *value )
4EGLBoolean eglDestroySync ( EGLDisplay dpy, EGLSync sync )
5EGLint eglClientWaitSync ( EGLDisplay dpy, EGLSync sync, EGLint flags, EGLTime timeout )
6// NOTE: native_display isn't actually an EGLAttrib. Using EGLAttrib
7// so that the generate creates mostly correct code (do not want a buffer)
8// have to manually change cast to (void *) in generated code that calls
9// the native function.
10EGLDisplay eglGetPlatformDisplay ( EGLenum platform, EGLAttrib native_display, const EGLAttrib *attrib_list )
11EGLSurface eglCreatePlatformWindowSurface ( EGLDisplay dpy, EGLConfig config, void *native_window, const EGLAttrib *attrib_list )
12EGLSurface eglCreatePlatformPixmapSurface ( EGLDisplay dpy, EGLConfig config, void *native_pixmap, const EGLAttrib *attrib_list )
13EGLBoolean eglWaitSync ( EGLDisplay dpy, EGLSync sync, EGLint flags )
14EGLImage eglCreateImage ( EGLDisplay dpy, EGLContext context, EGLenum target, EGLClientBuffer buffer, const EGLAttrib *attrib_list )
15EGLBoolean eglDestroyImage ( EGLDisplay dpy, EGLImage image )
16