1#!/usr/bin/make -f
2
3export DEB_BUILD_MAINT_OPTIONS = hardening=+all
4DPKG_EXPORT_BUILDFLAGS = 1
5include /usr/share/dpkg/buildflags.mk
6
7%:
8	dh $@
9
10override_dh_auto_configure: MAYBE_HOST_CPU=$(shell \
11	if [ "${DEB_BUILD_GNU_CPU}" = "i686" ]; then \
12	  echo "host_cpu=\\\"x86\\\"";\
13	elif [ "${DEB_BUILD_GNU_CPU}" = "x86_64" ]; then \
14	  echo "host_cpu=\\\"x64\\\"";\
15	elif [ "${DEB_BUILD_GNU_CPU}" = "aarch64" ]; then \
16	  echo "host_cpu=\\\"arm64\\\"";\
17	elif [ "${DEB_BUILD_GNU_CPU}" = "arm64" ]; then \
18	  echo "host_cpu=\\\"arm64\\\"";\
19	elif [ "${DEB_BUILD_GNU_CPU:0:3}" == "arm" ]; then \
20	  echo "host_cpu=\\\"arm\\\"";\
21	fi\
22)
23override_dh_auto_configure:
24	env
25	uname -a
26	gn gen out/release --args="is_debug=false use_custom_libcxx=false\
27	  is_hermetic_clang=false is_system_compiler=true is_clang=false\
28	  skip_buildtools_check=true enable_perfetto_integration_tests=false\
29	  enable_perfetto_unittests=false perfetto_use_system_protobuf=true\
30	  perfetto_use_system_zlib=true perfetto_enable_git_rev_version_header=false\
31	  extra_cflags=\"${CFLAGS}\" extra_cxxflags=\"${CXXFLAGS}\"\
32	  extra_ldflags=\"${LDFLAGS}\" cc=\"${CC}\" cxx=\"${CXX}\"\
33	  ${MAYBE_HOST_CPU}"
34
35override_dh_auto_build:
36	ninja -C out/release perfetto traced traced_probes
37
38override_dh_auto_clean:
39	rm -rf out/release
40