1From 6875449497baf026fb8228668930a715ffcc7082 Mon Sep 17 00:00:00 2001
2From: Sonny Sasaka <sonnysasaka@chromium.org>
3Date: Fri, 19 Mar 2021 16:56:59 -0700
4Subject: [PATCH] rebase_path for write_args
5
6---
7 BUILD.gn | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/libchrome/BUILD.gn b/libchrome/BUILD.gn
11index a846d8f52..66ac10a55 100644
12--- a/libchrome/BUILD.gn
13+++ b/libchrome/BUILD.gn
14@@ -556,7 +556,7 @@ action("base") {
15
16   script = "//common-mk/write_args.py"
17   outputs = [ "${root_out_dir}/lib/lib${target_name}.so" ]
18-  args = [ "--output" ] + outputs + [ "--" ] + [
19+  args = [ "--output" ] + rebase_path(outputs) + [ "--" ] + [
20            "GROUP",
21            "(",
22            "AS_NEEDED",
23@@ -618,7 +618,7 @@ action("base-test") {
24
25   script = "//common-mk/write_args.py"
26   outputs = [ "${root_out_dir}/lib${target_name}.a" ]
27-  args = [ "--output" ] + outputs + [ "--" ] + [
28+  args = [ "--output" ] + rebase_path(outputs) + [ "--" ] + [
29            "GROUP",
30            "(",
31            "AS_NEEDED",
32--
332.20.1
34
35